Jump to content
AVIC411.com
RonS

2017 v7 Mod: Nag Screen Removal Z, X, and F series

Recommended Posts

For those who have installed the 2017 release (v7.0), here is the Nag Screen Removal hack. Requires  supertestmode.zip (unzip it; copy TESTMODE.KEY to your FAT32 SD). 

This should work for Z110, Z120, Z130, Z140, X920, X930, X940. It should also work for F-series comparable models and likely others that have v7.0 firmware.
 
This is dangerous - especially for noobies. Make a backup of any files you change - in fact making a backup of all files under \USER is a good idea. Keep the original file(s) until you are sure everything is working correctly. It is very easy to accidentally delete files or whole directories in TestMode. Copying and Pasting files is a real PITA and is very error prone. I recommend watching the YouTube video by JasonH on using TestMode (even though he calls it HackMode for historical reasons). Do not install Hackmode!
 
Note: Install the 2017 map update before installing this hack. Do not change the file on the 2017 installation SD. If you do, the installation will fail. You will get the dreaded "Wrong SD" error.
 

Note: I have no way ATT to verify that the F series NAVI.EXE is the same binary, so it would be helpful if someone could verify the bytes below are correct at that location. If not, more research will be necessary.

 

Make a copy of the NAVI.EXE file on the 2017 update SD (in \UPDATE\USER\PRG\APL) to patch.
 
Then using a hex editor (such as HxD):
  at offset 0xBEC18  
  change 05 00 00 0A   to   00 00 A0 E1
and save the file.  HxD also has a binary file comparison that can  be used to make sure that only the above 4 bytes were changed.
 
Then use a separate SD with TESTMODE.KEY and the patched NAVI.EXE on it. With your headunit turned on, insert the above SD. It will boot into TestMode.
 
Go into File Maintenance.
 
First, you need to identify the "active" set of files. There are two \USER\PRGx directories on your HU. The active one is indicated by the presence or absence of a file named \USER\PRG.FLG  If this file is not present, the active application files are in \USER\PRG0\APL. Otherwise, the active files are in \USER\PRG1\APL. From now on I'll just call it the Active directory.
 
The goal is to replace the Active NAVI.EXE with the patched one using File Maintenance. Since TestMode will not allow you to overwrite an existing file, you need to delete the one already there.
 
Using TestMode, go to the Active directory and delete NAVI.EXE. Then go to the SD and select the patched NAVI.EXE and select Copy. Then go back into the Active directory and select Paste. It might take a minute to complete.
 
Then remove the SD and reboot your head unit. The app should start and allow you to see the map without presenting the annoying Nag Screen.

Share this post


Link to post
Share on other sites

Here's a pre-patched version of Navi.exe. Unzip then follow the instructions above to install on your unit. I can only recommend using this replacement file on North American units at this time. If you want to try it on F Series units, please report back if it works. Keep a backup of your old file just to be safe.

Navi_NoNag.zip

Share this post


Link to post
Share on other sites

Using the testmode.key but the paste function is highlighted but i can not select it.

 

So i deleted the navi.exe in the user/prg0/apl

i copied the navi.exe in my sd card

go to the apl directory

but the paste function does not work.

 

EDIT:

Solved... my god what a mess is this interface.. but hey.. it works.

Share this post


Link to post
Share on other sites

Hello RonS,

 

Thanks for all the information!!!

I tried to change change 05 00 00 0A   to   00 00 A0 E1 but they are not on the offset you said they are. I search and replace the bytes anyways but when I delete and copied the new Navi.exe the unit did not start correctly. So I pasted the old navi.exe without modifications and it restarted correctly. Thanks god!

 

Now, how do I find offset 0xBEC18. My file when I open it with HxD goes up to 006FE9F0 I don't see any x for example...

 

Do you know how I can make it work?

Thanks,

willylakes

Share this post


Link to post
Share on other sites

0x is simply a notation that the following number is hexadecimal (base 16), as opposed to octal (base 8 ), decimal (base 10), binary (base 2) ....

post-43400-0-18540000-1513389071_thumb.jpg

Share this post


Link to post
Share on other sites

In an attempt to give back instead of continually freeloading, here is a modification of RonS' ShortFuse script coupled to the patched Navi.exe in post #2 that was used successfully on a Z110BT after upgrading to the 2017 v7 US/Can Navi Maps.. .

    Instructions (almost verbatim, just copy&pasted with appropriate edits).  Held off directly attributing the post, lest anyone mistakenly tries to hold him liable:

"Here is the easy way to install the NoNag hack with no TestMode,  editing or patching involved.

Moderator note: WARNING: Only run this script if you are already running v7.0 firmware (2017 maps).  I did a binary file comparison between US and EU (v7.0) NAVI.EXE and they are identical. So these files may also work for F series units. Since the original files are copied to the SD, if there is a problem you can manually un-do this using TestMode. You could also copy the V7 NAVI.EXE from the 2017 update files.

Just download this attached zip, unzip, and copy the 3 files to the root of a blank fat32 formatted SD. When you insert it into your AVIC it runs a script that will backup both your existing Navi.exe files, then overwrite them with a patched one."

When you insert the SD, it will prompt you to press any key (button) to continue - or - turn off the ignition to abort.  If you decide to abort, just turn off and on your unit - then eject the SD. Nothing on your unit will have changed."

Same rules apply:

  • Contains the special scripting-specific version of TESTMODE.KEY
  • Deletes the TESTMODE.KEY immediately after initialization to avoid overwriting the original Navi.exe back-ups created on the SD from the unit itself (labeled Navi.ex0 & Navi.ex1), if the card is left in or reinserted again.
  • Can't hold me liable either.

Navi_NoNag_Script.zip

Share this post


Link to post
Share on other sites
13 hours ago, commando528 said:

In an attempt to give back instead of continually freeloading, here is a modification of RonS' ShortFuse script coupled to the patched Navi.exe in post #2 that was used successfully on a Z110BT after upgrading to the 2017 v7 US/Can Navi Maps.. .

Thanks. I thought about doing something like that but I didn't want to deal with figuring out (in the script) which PRG directory to update. Now, I realize it doesn't matter - just do both. The non-active directory NAVI.EXE will never be run again. And next update (2018?) will overwrite it anyway. Brilliant.

BTW, I added a warning so some fool doesn't brick his unit with an incompatible program.

Share this post


Link to post
Share on other sites
47 minutes ago, densil101 said:

Can anyone confirm that this definitely works for the F series?

Many thanks!!

It is easily reversible if it doesn't work.

Share this post


Link to post
Share on other sites
2 hours ago, densil101 said:

I can confirm that it does work on the F series. Many thanks for all your work.

Great. Which model? I guess it shouldn't matter as long as it is compatible with v7 (2017) firmware. But it is nice to know the proven successes.

Share this post


Link to post
Share on other sites
On 9/13/2017 at 3:30 AM, seth_space said:

Using the testmode.key but the paste function is highlighted but i can not select it.

 

So i deleted the navi.exe in the user/prg0/apl

i copied the navi.exe in my sd card

go to the apl directory

but the paste function does not work.

 

EDIT:

Solved... my god what a mess is this interface.. but hey.. it works.

I am having this same problem with the paste... i deleted the Existing navi.exe but cannot paste. What was the method you used...??

i figured this out by re watching the youtube video and doing it how he did to Paste. But now I got a new problem.

 

thanks

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×