Jump to content

Complete 3.0 Install Guide

Recommended Posts

  • Replies 967
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

ONLY DOWNLOAD FILES IF YOU OWN THE RIGHTS TO USE 3.0 Retell nor Avic411 Condones Piracy. Please note this is not the official Retail Pioneer 3.0 Update! If you break your unit, Pioneer will NOT fix

Posted Images

I have had my European F900BT for a couple of years, and hacked into it soon after purchasing using a mod by Stanislavovich from 4PDA with great assistance from Boris and others, and a few tweaks from me which I posted.


I was very satisfied with it, indeed I still am, but face a problem in that I seem to be unable to update maps as I did not upgrade to v3 and therefore need IGO8 rather than IGO8.3 maps.


I am therefore going to bite the bullet and upgrade to v3 using your technique, and then use one of the many v3 mods that appear to be available on this site, and download up-to-date IGO8.3 maps.


To date have downloaded the rar files and extracted them to a folder on my laptop. However, as I will only be using the Navi in the UK and France I propose to delete all the US maps, POI and building files, and replace them with equivalent UK and France files. Do you agree that this would be ok? Presumably I should retain the existing basemap file.


I am grateful for your help in putting this together.



Link to post
Share on other sites
  • 3 weeks later...

I just performed the 3.0 upgrade, but the unit is not in my vehicle. I am using my 12v bench tester. I have the red and yellow wires attached to the positive, and the the ground attached to the negative. This allows me to test radios. I have three F700BT's I picked up pretty cheap. I followed the directions to the letter. At the end when it was done, I ejected the SD card, held the reset button for 5 seconds. The splash screen came up, then went black, and stay that way. Did I do something wrong?

Link to post
Share on other sites
  • 2 weeks later...

I've tried reinstalling this 3 times, but consistently get the "System is starting up" message on the screen. I'm not even sure where I got my 3.0 image from at this point. Could someone upload the one they used on their system to megashare or something? That would be so awesome. Really would love to get this working ASAP.



Link to post
Share on other sites
  • 2 weeks later...



When I get into the service menu, my screen will go black after 20 or so seconds. Even once I get to Update via SD (Format) and I click it, it will start reading the files and then the unit will just go black. This happens every time, even if I go into the service menu but don't click anything. When I reboot the unit (without trying to get into the service menu), the screen just stays black, nothing comes up. I have 2.006 installed on my F900.


Once I reboot the unit I can successfully get back into the service menu, but then it goes to black screen.


I had the same problem with my AVIC F700BT when I tried to upload 3.0... I followed the directions, on this forum, then did it again and the update took. It took twice for me to upload the files via test mode for the update to take, then voila no black screen. You should refer to the dude who uploaded the files onto megaupload, his directions were money. And from there I updated to 3.2 directly (No you do not need to update to 3.1 to get 3.2 despite what people tell you, mine installed just fine from hacked 3.0, without fooling with 3.1.)

Link to post
Share on other sites
  • 4 weeks later...

There are 861 prior posts in this thread, many of which are now outdated. I have an AVIC-F900BT that did the usual boot screen to black brick and was determined to fix it. A HUGE thanks to everyone on this forum for the collection of info to get my unit up and running with an even better interface (2.0 to 3.0 upgrade in the process).


I wanted to update the instruction process due to post 1 being a little inaccurate with the new links and software but give most credit to Retell as OP and MyITGuy for providing the new software links and info for slight modifications for the instructions.


These instructions should solve most problems and get you up and running with 3.0. Some people have started adding info for a 3.01 update (Post 717) and 3.02 update but I have not yet gotten that far. Here we go!


Step 1: Download 2 rar files, 3.0 Update, part 1 and part 2*





(*Thanks MyITGuy for the links, post #600)


Step 2: Unrar these files

Mac OS X - UnRarX - http://www.unrarx.com/ (This is what I used)

Windows - WinRar - http://www.win-rar.c...ownloadnow.html


a. You will select 3.0 Update, part 1 to open

b. Unrar it to the desired location

c. You are done! While unrarring (if that's a word) part 1, it will also unrar all files in part 2 without needing to do anything additional.

d. You should now have a destination file with 4 items

1. My Flash Disk - Folder

2. Testmode - Folder

3. WINCEIMG.Bin - File



(Note: I came across a few posts where people said they had issues with the included Testmode and downloaded a fresh file to replace the included one. To save myself time, I went ahead and did this upfront without actually ever testing the one included. If you choose to do this as well, you can get another functional Testmodev2.3 here - http://www.filestube...0f503ea/go.html. Again, I never tested the included one and may be perfectly fine. If you download a new copy, just replace the old Testmode folder in your destination directory with the new one once you unrar it.)



Step 3: Make sure you have an SD card that is 2GB or larger, and format it using MS-DOS (Fat) formatting. Transfer the 4 items from your destination folder to the SD Card. (My Flash Disk, Testmode, WINCEIMG.BIN, WINCEIMG.CKS)


Step 4: Turn the unit on. When the Pioneer logo comes up, press and hold the menu, map, eject and the reset button at the same time. When your screen goes completely blank, let go of the reset button but continue to hold menu, map, and eject buttons.* This will bring you to a blue screen wanting you to press the reset button again. Ignore this message and enter the service combination. Press the volume knob in this sequence and you will see * signs for each push at the botton: Up, Up, Down, Menu, Left, Right.


(*Thanks Chuck88, post 813)


Step 5: Insert your loaded SD


Step 6: Select Update CE


Step 7: Select Update SD Format


Step 8: Wait till it says restart in the bottom center.


Step 9: Press the reset button.


Step 10:

Once testmode boots (You will have a WindowsCE screen):

a. Select "Start"

b. Select "Windows Explorer"

c. Double-click "My SD Card"

d. Double-click "My Flash Disk" folder

e. Click "Edit" and select "Select All"

f. Click "Edit" and select "Copy"

g. Press the up folder icon twice to get you back to the main Windows Explorer screen

h. Double-click "My Flash Disk"

i. Click "Edit" and select "Paste"

j. A window will open asking if you want to over-rite existing files, select "Yes to all"

This process will take about 30 minutes.


Step 11: Press and hold restart and eject for 5 seconds.


Step 12: Enjoy your new 3.0 biggrin.gif


Again, this is a compilation of info and not my work. I'm not capable of doing what half of these people do, I'm just a guy that can read directions. I was getting tired of the people going from the start to the finish to ask about dead links without looking at the meat in the middle Yes, I'm talking to you! You're an idiot. Read!!! We can't spoon feed you, you still have to do some of it yourself once in a while. Please do not contact me with your problems, I probably can't help you. If it didn't work, either it really is broke or start again with step 1.


I followed these instructions about 20 times through, i cant figure out how to get them to work. right now my system will only boot into test mode. i was on version 2.0000 when i started. how do i fix this? if i try to let it boot without the crad that has test mod it just stays on the flashcard forever. please help anyway you can.



Link to post
Share on other sites
  • 3 weeks later...
  • 1 month later...


I followed these instructions about 20 times through, i cant figure out how to get them to work. right now my system will only boot into test mode. i was on version 2.0000 when i started. how do i fix this? if i try to let it boot without the crad that has test mod it just stays on the flashcard forever. please help anyway you can.




I am stuck too... When I finish copying the files over do I take the memory card out and then press and hold reset+eject for 5 seconds or do I do this with the card still in the system?

Link to post
Share on other sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...